[GRASS-Italia] installazione di Grass su suse 10.0

Roberto Antolin roberto a geomatica.como.polimi.it
Mar 13 Feb 2007 18:37:13 CET


Ciao a tutti,

>>Dopo aver risoltp i problemi legati alle librerie mancanti.
>>Provo ad eseguire i comandi
>># rpm -Uhv geos-2.2.3-1suse10.0.i586.rpm \
>># proj-4.5.0-1suse10.0.i586.rpm \
>># gdal-1.3.2-1suse10.0.i586.rpm \
>># grass-6.2.1-1suse10.0.i586.rpm \
>># gdal-grass-1.3.2-1suse10.0.i586.rpm 
>>
>>e la shell mi da il seguente output: 
>>error: cannot get exclusive lock on /var/lib/rpm/Packages
>>error: cannot open Packages index using db3 - Operations not permitted (1)
>>error: cannot open Packagest database in /var/lib/rpm
>>
>>
>>Che cosa posso fare?
>>    
>>
>Sei "root"  quando tenti di istallare i pacchetti?
>  
>
A parte di essere "root", hai visto se i pacchetti sono giŕ installati 
ma con una versione anteriore? Voglio dire, "rpm -U" fa l'upgrade dei 
pacchetti. Se invece vuoi installare devi usare "rpm -i"

Saludos,
Roberto.

-- 
Roberto Antolín Sánchez
Politecnico di Milano – Polo Regionale di Como
(Laboratorio di Geomatica V2.8)
Via Valleggio, 11 – 22100 Como, Italy
tel: +39 031 332 7533 || fax: +39 031 332 7519 
email: roberto.antolin a polimi.it




Maggiori informazioni sulla lista GRASS-Italia